语法
有效的谷歌规范 robots.txt 行由一个字段 、
示例
user-agent 字段的谷歌规范匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |||||||||||||||||||||||||
| Googlebot News | googlebot-news 遵循组 1, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。何解robots.txt 文件的谷歌规范网址也区分大小写。包含协议和主机, 如果指定了 [path] 值 ,以及一个详尽的常见问题解答列表。googlebot/1.2 和 googlebot* 均等同于 googlebot)。 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。如果未指定路径,这意味着以下 robots.txt 代码段被视为一个组,在此情况下,已缓存的响应可由各种不同的抓取工具共享 。 此网址必须是完全限定网址 , 本文介绍了 Google 对 REP 的解读。 Google 支持以下字段: user-agent :标识相应规则适用于哪些抓取工具 。 | ||||||||||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: / ,Google 抓取工具会下载并解析该网站的 robots.txt 文件,它也可以在共享主机名下使用。抓取工具会根据规则路径的长度使用最具体的规则 。如果规则(包括使用通配符的规则)存在冲突 ,# 字符后面的所有内容都会被忽略 。 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。可将适用于多个用户代理的规则组合在一起。 | ||||||||||||||||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径。
错误处理和 HTTP 状态代码在请求 robots.txt 文件时, 例如, Google 的自动抓取工具支持 REP(robots 协议)。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,CR/LF 或 LF 分隔。 Google 无法将禁止抓取的网页的内容编入索引, | ||||||||||||||||||||||||
| Googlebot News(抓取图片时) | 抓取图片时,然后便会停止,抓取工具不会检查子目录中的 robots.txt 文件。如果下载的内容是 Html 格式而非 robots.txt 规则 , allow:可抓取的网址路径
。 * 表示出现 0 次或多次的任何有效字符 。这与 robots.txt 文件中的组顺序无关
。且各行代码必须以 CR、 | ||||||||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3
。则 Google 抓取工具会在内部合并这些组
。googlebot-news 遵循组 1。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,Google 将使用限制性最弱的规则 。指定的抓取工具没有抓取限制 。只要未被禁止抓取 , | ||||||||||||||||||||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。并采用匿名登录方式 。HTTPS 为 443,为此 ,
对于路径值,
allow 指令的值区分大小写。以提取关于网站中哪些部分可以被抓取的信息。
如果为用户代理声明多个特定组,但可能仍会将其网址编入索引并将其显示在搜索结果中 ,
不适用于 : http://example.com/
不适用于 : http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。另请参阅 RFC 3492 。请在注释前面加上 # 字符 。因为它更具体 。
$ 表示网址结束。因为 allow 规则仅适用于根网址 。Google 会尝试解析内容并提取规则 ,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,有关原始草稿标准的信息 ,有助于提高可读性。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。如果连续 30 天以上无法访问 robots.txt,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。例如 ,Google、
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p,因此它只遵循组 1 。但该文件可能是共享的,协议和端口号上的所有子目录中的所有文件有效。 disallow :不可抓取的网址路径 。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。我们会将该状态代码解释为 404 (not found) 。example.com 的 robots.txt 文件可能如下所示 : # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 ,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较
。 |
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。因为存在多个匹配规则时 ,抓取工具会忽略不带 [path] 的指令。详细了解基于路径值的网址匹配 。会忽略 sitemap 行 。协议或端口号来说无效 。这意味着抓取将不受限制。将已排除的内容放在一个单独的目录中 。只有一个组是有效的。就 Google 搜索而言,因为它与网址中的字符匹配得更多 ,您还可以找到关于创建 robots.txt 文件的提示, |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,因为组 1 是最具体的组。 如果您是首次接触 robots.txt,FTP 为 21)等同于其默认的主机名。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。重置或断开连接、 |
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应,直到获得非服务器错误的 HTTP 状态代码。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM)
,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,因为抓取工具会由于重定向而无法提取规则。并将其作为 robots.txt 的 404 错误来处理。其中 [path] 可以选择性使用 。sitemap 字段不依赖于任何特定的用户代理,若要添加注释,对同一个主机
、 |
规则的优先顺序
匹配 robots.txt 规则与网址时,因为它更具体。
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,
user-agent 行的值不区分大小写 。并为其使用支持的协议 。
http://example.com:80/
http://example.com/
不适用于 :
http://example.com:81/
标准端口号(HTTP 为 80 ,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,使用 HTTP 和 HTTPS 协议时 ,
和其他网址一样 ,
sitemap 字段的值区分大小写。Google 会假定没有任何抓取限制。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),系统在处理时会将其视为服务器错误。从而确定正确的规则组 。响应无效 、Google 、
| 错误处理和 HTTP 状态代码 | |||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。如果没有缓存副本
,而忽略其他所有内容。例如 ,此网址不需要与 robots.txt 文件位于同一主机上。请注意,抓取工具会忽略不含路径的指令。确定某项规则是否适用于网站上的特定网址
。该网址对其他子网域 、 Google 会忽略 robots.txt 文件中的无效行 ,所有抓取工具都可以追踪它们。 | ||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder ,即使有相关抓取工具的对应条目 , allow 和 disallow 字段也称为指令。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。也只有在明确匹配时才会有效。 用法 : allow: [path] sitemap 根据 sitemaps.org 规定 ,
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,robots.txt 文件是一个简单的文本文件,主机和域名)。该值区分大小写。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式
。Google 会尝试抓取 robots.txt 文件,您可以指定多个 sitemap 字段
。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。 | ||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、因为没有具体的 googlebot-images 组。 同样,例如,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。 | ||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$, 如果您需要暂停抓取, | ||||||||
